Video Player for USB DAC (exclusive mode)

Discussion in 'Audio Equipment' started by quadibloc, Feb 27, 2014.

  1. quadibloc

    quadibloc Guest

    Inspired by a recent review of the AudioQuest Firefly DAC in the latest issue of TAS, I went out and ended up buying another product of that general type, a Meridian Explorer.

    When playing videos in VLC, I noted the lights on the unit showed it was handling a 192000 samples/sec stream, although the codec info in VLC said theaudio was only at 44100.

    To make a long technical story short, this is because sound in Windows is normally played in "shared mode" instead of "exclusive mode". Some programs do use exclusive mode, where one program takes full control of a given sound card, and can change its sample rate, but that often results in problems like my sound for everything else goes dead when program X starts.

    Well, I can tell VLC to use the Meridian even if it isn't the default audiodevice (you need to see "all" settings, and go into Output Modules - I setit for both Wave Out and DirectX, as I had no idea which one it was using....). So if it grabs exclusive use of the Meridian, that won't interfere with other sounds.

    But VLC doesn't have WASAPI support yet, and apparently that's what offers exclusive mode in Win7.

    I saw a recommendation to use ReClock by SlySoft for this, but that seems to be made to work with their products, and it's mostly about changing the video scan rate to match that of the DVD you're watching.

    Also, I thought I saw statements to the effect that the audio player program Foobar (or is it Foobar2000) does have this capability. So is there a different video player I should use, or some Windows setting I've missed, to avoid unnecessary resampling?

    John Savard
     
    quadibloc, Feb 27, 2014
    #1
    1. Advertisements

  2. quadibloc

    John Savard Guest

    It wasn't obvious, but when I installed the WASAPI plugin for Foobar2000, and then chose the Meridian with WASAPI as my output device, it automatically went to exclusive mode without my having to explicitly specify it.

    So now I've finally played music on the Meridian without all the lights going on (yes, of course _that_ could be achieved by lowering the bitrate for shared mode, but that would limit sound quality).

    John Savard
     
    John Savard, Feb 27, 2014
    #2
    1. Advertisements

  3. quadibloc

    John Savard Guest

    I think I've found the solution to my problem.

    VLC does have the ability to use WASAPI, but this was introduced in version2.1.0, and I was running version 2.0.4 - the current version is 2.1.3. So updating to the current version will solve my problem (Foobar2000 doesn't play even the audio part of video files, and it seems to be lacking other features as well, but maybe if I worked with it more I'd find out where they were.)

    John Savard
     
    John Savard, Feb 27, 2014
    #3
  4. quadibloc

    John Savard Guest

    That does not seem to have solved the problem, it is not leading to bit-accurate output.

    John Savard
     
    John Savard, Mar 1, 2014
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.